
<!DOCTYPE html>
<html class="root root_js_disabled">
    <head>
        <meta charset="utf-8" />
        <meta name="viewport" content="width=1170" />
        <meta name="site" content="kagstv.com" />
        <script>
            document.documentElement.classList.remove('root_js_disabled');
        </script>
        <noscript>
            <style>
                * {
                    transition: none !important;
                    animation: none !important;
                }
                .page__desktop-header {
                    position: static;
                    top: auto;
                    left: auto;
                    right: auto;
                    bottom: auto;
                }
                .desktop-header__nav-wrapper {
                    z-index: 3;
                    opacity: 0;
                    width: 70px !important;
                    height: 50px !important;
                    transform: translateX(-655px) translateY(23px);
                    transition: none;
                }
                .desktop-header__navigation_visible_false {
                    transition: none !important;
                    overflow: visible !important;
                }
                .desktop-header__nav-wrapper:hover {
                    height: auto !important;
                    transform: none;
                    opacity: 1;
                    transition: none;
                }
                .desktop-header__nav-wrapper:hover .desktop-header__navigation_visible_false {
                    opacity: 1;
                    transform: translateX(-670px) translateY(-98px) !important;
                    padding-top: 100px;
                }
                .grid__cell[data-columns="12"] .ad,
                .page__footer .ad__nojs-placeholder {
                    display: none !important;
                }
                .grid__cell[data-columns="12"] [data-module="ad"] {
                    display: none !important;
                }
                .grid__module[data-module="headline-list-with-abstract"] .ad__nojs-placeholder {
                    display: none !important;
                }
            </style>
        </noscript>
        <script>
            function appendStyle(url) {
                var sheet = document.createElement("link");
                sheet.setAttribute("href", url);
                sheet.setAttribute("rel", "stylesheet");
                sheet.setAttribute("type", "text/css");
                document.head.appendChild(sheet);
            }
        </script>
        <link rel="stylesheet" href="/Views/dist/styles/modules.min.css?version=3.7.2" />
        <script>
            appendStyle('/Views/lib/jquery-ui/jquery-ui.min.css');
            appendStyle('/Views/lib/jquery-ui/jquery-ui.structure.min.css');
            appendStyle('/Views/lib/jquery-ui/jquery-ui.theme.min.css');
        </script>
        <!--[if IE]><link rel="shortcut icon" href="/content/favicon/KAGS.png?version=3.7.2"><![endif]-->
        <link rel="icon" href="/content/favicon/KAGS.png?version=3.7.2">
        <meta property="fb:app_id" content="1937221269873256" />
        <meta property="og:site_name" content="KAGS" />
        <meta property="og:locale" content="en_US" />
        <meta itemprop="pageType" content="article" />
        <meta name="description" content="May the fourth be with you! Here are some great deals for &#39;Star Wars&#39; fans." />
                    <script>
                var tealiumUrl = 'https://tags.tiqcdn.com/utag/tegna/kags-redesign-desktop/prod/utag.js';
                var utag_data = {
                    //Original Set
                    template_type: "", // ux name for page layout
                    page_type: "article",
                    division: "Broadcast",
                    site_type: "desktop",
                    page_url: window.location.href,
                    simplerreach_tags: "",
                    pathname: "https://www.kagstv.com/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/499-4cfb0912-d861-4a24-aed4-acbc9d293e00",
                    ad_slots: [],
                    gpt_network_code: "32805352/tx-collegestation-KAGS-B3362_DesktopTablet",
                    //Occurring in Both Sets
                    section: "money",
                    subsection: "consumer",
                    topic: "dealboss",
                    subtopic: "",
                    content_type: "article",
                    category: "money",
                    market: "Bryan" + ", " + "TX",
                    //New Set
                    subcategory: "consumer",
                    keywords: "KAGS, Bryan, Texas, news, local news, breaking news, traffic, weather, sports, events,KAGS",
                    document_title: "KAGSTV.com",
                    canonical_url: "https://www.kagstv.com/article/news/star-wars-day-deals-2019/507-4cfb0912-d861-4a24-aed4-acbc9d293e00"
                };
            </script>
        <script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "Organization",
            "url": "https://www.kagstv.com",
            "logo": "https://www.kagstv.com/content/logos/mobile/kags.png",
            "sameAs": [
            "https://www.facebook.com/KAGSTV",
            "https://twitter.com/KAGSnews"
            ]
            }
        </script>
        <script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "WebSite",
            "url": "https://www.kagstv.com",
            "potentialAction": {
            "@type": "SearchAction",
            "target": "https://www.kagstv.com/search?q={search_term_string}",
            "query-input": "required name=search_term_string"
            }
            }
        </script>
            <meta itemprop="datePublished" content="5/1/2019 8:50:02 PM" />
            <meta itemprop="dateModified" content="5/1/2019 8:50:02 PM" />
            <meta itemprop="url" content="https://www.kagstv.com/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/507-4cfb0912-d861-4a24-aed4-acbc9d293e00" />
            <meta itemprop="magnet:custom" name="category" content="money" />
            <meta property="og:url" content="https://www.kagstv.com/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/507-4cfb0912-d861-4a24-aed4-acbc9d293e00">
            <meta property="og:title" content="'Star Wars' Day 2019: the 20 best May the Fourth deals">
            <meta property="og:description" content="May the fourth be with you! Here are some great deals for &#39;Star Wars&#39; fans.">
            <meta property="og:type" content="article" />
            <meta property="og:image" content="https://media.kagstv.com/assets/CCT/images/380f746c-4e16-4679-a7ac-d29e79124196/380f746c-4e16-4679-a7ac-d29e79124196_1140x641.jpg">
            <meta property="og:image:width" content="1140" />
            <meta property="og:image:height" content="641" />
            <meta property="og:article:published_time" content="5/1/2019 8:50:02 PM" />
            <meta name="twitter:title" content="'Star Wars' Day 2019: the 20 best May the Fourth deals">
            <meta name="twitter:image:src" content="https://media.kagstv.com/assets/CCT/images/380f746c-4e16-4679-a7ac-d29e79124196/380f746c-4e16-4679-a7ac-d29e79124196_360x203.jpg">
            <meta name="twitter:card" content="summary">
            <meta name="twitter:site" content="KAGSnews">
            <meta name="twitter:description" content="May the fourth be with you! Here are some great deals for &#39;Star Wars&#39; fans.">
            <meta name="twitter:domain" content="www.kagstv.com">
            <link rel="canonical" href="https://www.kagstv.com/article/news/star-wars-day-deals-2019/507-4cfb0912-d861-4a24-aed4-acbc9d293e00" />
            <link rel="alternate" href="https://www.kagstv.com/mobile/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/507-4cfb0912-d861-4a24-aed4-acbc9d293e00" />
                <link rel="amphtml" href="https://www.kagstv.com/amp/article?section=money&amp;subsection=consumer&amp;topic=dealboss&amp;headline=star-wars-day-2019-the-20-best-may-the-fourth-deals&amp;contentId=507-4cfb0912-d861-4a24-aed4-acbc9d293e00" />
                <script>
                if (window.utag_data) {
                    //Original Set
                    utag_data.video_included = "true";
                    utag_data.article_date = "5/1/2019 8:50:02 PM";
                    
                    utag_data.msj_tag = "";
                    if ("text" === "text")
                    {
                        utag_data.item_number = 1;
                    }
                    //Occurring in Both Sets
                    utag_data.asset_id = "4cfb0912-d861-4a24-aed4-acbc9d293e00";
                    utag_data.article_keywords = "dealboss,money,consumer,entertainment,life";
                    utag_data.content_title = "'Star Wars' Day 2019: the 20 best May the Fourth deals | DEALBOSS";
                    utag_data.original_headline = "'Star Wars' Day 2019: the 20 best May the Fourth deals";
                    utag_data.content_categories = "dealboss,money,consumer,entertainment,life";
                    //New Set
                    utag_data.article_byline = "Matt Granite";
                    utag_data.topics_included = "false"; //whether related topics are present, may be able to remove since not using Klangoo

                    if ("" === "video")
                    {
                        utag_data.video_included = "true";  //if lead asset is video
                        utag_data.video_autoplay = "true";  //if lead asset is autoplay
                    }
                }
                </script>
            <title>'Star Wars' Day 2019: the 20 best May the Fourth deals | DEALBOSS | kagstv.com</title>
                         <style>
        .fc-pinned-header:after {
            background: #000000 url('/content/logos/dark/KAGS.png') calc(100% - 45px) 10px no-repeat;
            background-size: auto 25px;
            content: 'Ad blocker detected';
        }
        .fc-dialog-header:after {
            background: #000000 url('/content/logos/dark/KAGS.png') calc(100% - 20px) 10px no-repeat;
            background-size: auto 25px;
            content: 'Ad blocker detected';
        }
        </style>
                <script src="//js-sec.indexww.com/ht/p/184603-27872873504810.js"></script>
        <script>
                if (!window.tgnaA9ApstagLoaded) {
                    try {
                        !function (a9, a, p, s, t, A, g) {
                            if (a[a9]) return; function q(c, r) { a[a9]._Q.push([c, r]) } a[a9] = {
                                init: function () { q("i", arguments) }, fetchBids: function () { q("f", arguments) }, setDisplayBids: function () { }, _Q: []
                            }; A = p.createElement(s); A.async = !0; A.src = t; g = p.getElementsByTagName(s)[0]; g.parentNode.insertBefore(
                                A, g)
                        }("apstag", window, document, "script", "//c.amazon-adsystem.com/aax2/apstag.js");
                    } catch (e) {
                        console.log('Error loading apstag.js');
                    }
                }
        </script>
    </head>
    <body id="page"
          class="page"
          data-model-siteid="499"
          data-model-gptid="tx-collegestation-KAGS-B3362_DesktopTablet"
          data-model-callletters="KAGS"
          data-model-primarydomain="kagstv.com"
          data-model-imageresizeurl="https://www.kagstv.com/img/resize/"
          data-model-imageresizeurl-wx="https://www.kagstv.com/img/wx/resize/"
          data-model-city="Bryan"
          data-model-state="TX"
          data-model-fban="1937221269873256"
          data-model-refresh="420"
          data-model-metadata="{
  &quot;title&quot;: &quot;KAGSTV.com&quot;,
  &quot;keywords&quot;: &quot;KAGS, Bryan, Texas, news, local news, breaking news, traffic, weather, sports, events,KAGS&quot;,
  &quot;contentType&quot;: &quot;article&quot;,
  &quot;pageType&quot;: &quot;article&quot;,
  &quot;continiousScrollSettings&quot;: {
    &quot;providers&quot;: [
      &quot;database&quot;,
      &quot;database&quot;,
      &quot;database&quot;,
      &quot;database&quot;,
      &quot;database&quot;
    ],
    &quot;default&quot;: &quot;database&quot;
  },
  &quot;platform&quot;: &quot;desktop&quot;
}"
          data-model-timezone="Central"
          data-model-twitterid="KAGSnews"
          data-model-omnitureid="0"
          data-model-googleanalytics="453"
          data-model-tealiumgpt="493"
          data-model-version="3.7.2"
          data-model-closings="true"
          data-model-gptnetworkcode="32805352"
          data-model-comscoreid="19962895"
          data-model-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah"
                        data-model-cscrollsectionpriority="false"
          data-model-ispreview="false">
        <div id="fb-root"></div>
            <div class="page__desktop-header">
<div class="desktop-header desktop-header_collapsed_false">
    <div class="desktop-header__wrap">
        <div class="desktop-header__inner">
            <div class="desktop-header__toolbar">
<div class="toolbar">
    <div class="toolbar__live-indicator">
<div class="live-indicator live-indicator_collapsed_false">
                <div class="live-indicator__info live-indicator__info_visible_true">
                    <div class="live-indicator__cta">
                        <div class="live-indicator__watch-live">WATCH LIVE</div>
                        <div class="live-indicator__watch-time">On Air 5:50PM</div>
                    </div>
                </div>

</div>
    </div>
    <div class="toolbar__weather-summary">
<div class="weather-summary">
    <a class="weather-summary__link" data-tracking="weather-summary/weatherClicked" href="/weather">
        <div class="weather-summary__icon weather-icons weather-icons_icon_66"></div>
        <span class="weather-summary__current-temperature">81</span>
        <div class="weather-summary__location">Bryan, TX</div>
        <div class="weather-summary__weather-conditions-container">
            <p class="weather-summary__weather-conditions">Bryan Weather Summary: 81 degrees</p>
        </div>
        <!-- span class="weather-summary__details">
        <span class="weather-summary__high-low weather-summary__high-low_visible_true">
            <span class="weather-summary__high-low-icon"></span>
            <span class="weather-summary__high-low-label" title="high">H</span>
            <span class="weather-summary__high-low-temperature weather-summary__high">86</span>
            <span class="weather-summary__high-low-separator">/</span>
            <span class="weather-summary__high-low-label" title="low">L</span>
            <span class="weather-summary__high-low-temperature weather-summary__low">71</span>
        </span>
    </span -->
    </a>
</div>

    </div>
</div>
            </div>
            <div class="desktop-header__nav-button"><div class="desktop-header__nav-label">Menu</div></div>
            <div class="desktop-header__badges"></div>
            <a class="desktop-header__home-link desktop-header__home-link_visible_true" href="/" data-tracking="desktop-header/homeLinkClicked">
                <img class="desktop-header__logo" src="/content/logos/mobile/kags.png" />
            </a>
            <div class="desktop-header__article-title"></div>
        </div>
        <div class="desktop-header__progress desktop-header__progress_visible_false">
<progress class="progress" value="0"></progress>
        </div>
    </div>
    <div class="desktop-header__nav-wrapper">
        <div class="desktop-header__navigation desktop-header__navigation_visible_false desktop-header__navigation_collapsed_false">

<div class="navigation navigation_visible_false">
    <div class="navigation__main">
    <div class="navigation__main-inner">
        <div class="navigation__searchbox">
<div class="searchbox">
    <form class="searchbox__form" action="/search">
        <div class="searchbox__main">
            <input class="searchbox__textbox searchbox__textbox_name_q" name="q" placeholder="Search"/>
            <button class="searchbox__submit" type="submit"></button>
        </div>
        <label class="searchbox__labeled-field">
            <input class="searchbox__checkbox searchbox__checkbox_name_phrase" type="checkbox" name="phrase" />
            <span class="searchbox__label">Exact phrase</span>
        </label>
    </form>
</div>
        </div>
        <div class="navigation__notification-container">
            <div class="navigation__notification">
                <div class="navigation__notification-title">KAGS Alert Center</div>
                <div class="navigation__notification-list">
                        <a class="navigation__notification-label navigation__notification-label_name_live-videos navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/live-video">Live Video</a>
                                            <a class="navigation__notification-label navigation__notification-label_name_breaking-news navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/breaking-news">Breaking<br />News</a>
                                            <a class="navigation__notification-label navigation__notification-label_name_weather navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/severe-weather">Weather</a>
                                                <a class="navigation__notification-label navigation__notification-label_name_closings navigation__notification-label_active_false" data-tracking="navigation/alertCenterClicked" href="/closings">Delays/<br />Closings</a>
                </div>
            </div>
        </div>
        <ul class="navigation__sponsored-list">
            <li class="navigation__sponsored-by">Sponsored by</li>
            <li class="navigation__sponsored-item">
                <a class="navigation__sponsored-link" data-tracking="navigation/sponsoredLinkClicked" href="/attheborder">
                    <img class="navigation__sponsored-image" src="https://cdn.tegna-media.com/wbir/assets/attheborder-352x52.png" alt="At the Border" />
                    <div class="navigation__sponsored-go-indicator"></div>
                </a>
            </li>
        </ul>
        <noscript>
            <div class="navigation__item navigation__item_children_false" style="border-top:1px solid #e6e6e6">
                <a class="navigation__sublist-activator" href="/">
                    <span class="navigation__label">Home</span>
                </a>
            </div>
        </noscript>
        <ul class="navigation__list">
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_news" href="/news" >News</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                            <ul class="navigation__sublist navigation__sublist_special_true navigation__sublist_visible_false">
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_local navigation__sublink_special_true" href="/local" >Local</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_money navigation__sublink_special_true" href="/money" >Money</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment-news navigation__sublink_special_true" href="/entertainment" >Entertainment</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-nationworld navigation__sublink_special_true" href="/nation-now" >Nation World</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-health navigation__sublink_special_true" href="/health" >Health</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news-politics navigation__sublink_special_true" href="/politics" >Politics</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life navigation__sublink_special_true" href="/life" >Life</a></li>
                                            <li class="navigation__subitem navigation__subitem_special_true"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_community navigation__sublink_special_true" href="/community" >Community</a></li>
                            </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_weathertraffic" href="/weather" >Weather &amp; Traffic</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather" href="/weather" >Current Weather</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather~radar" href="/radar" >Radar</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather~maps" href="/weather-maps" >Maps</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather~7-day" href="/10-day" >Hourly &amp; 10-Day</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather~closings" href="/closings" >Closings &amp; Delays</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_traffic~gas-prices" href="/gas-prices" >Gas Prices</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_traffic~driving-smart" href="/driving-smart" >Driving Smart</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_weather~cameras" href="/sky-cam" >Sky Cam</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_sports" href="/sports" >Sports</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports" href="/sports" >Latest Sports</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports~ncaa~aggies" href="/aggies" >Aggie Sports</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports~ncaa~blinn" href="/blinn" >Blinn Sports</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports~high-school" href="/hss" >High School Sports</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_sports~ncaa~brazos-valley-bombers" href="/brazos-valley-bombers" >Brazos Valley Bombers</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_features" href="/features" >Features</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~special-reports~at-the-border" href="/attheborder" >At the Border</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~community" href="/community-calendar" >Community Calendar</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~community" href="https://corps.tamu.edu/"  target=&quot;_blank&quot;>Aggie Corps</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_money~consumer~dealboss" href="/dealboss" >DEALBOSS</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life~food" href="/food" >Food</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~education~local-schools" href="/local-schools" >Local Schools</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_life~pets~pet-of-the-week" href="/petoftheweek" >Pet of the Week</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink" href="https://www.shopdealboss.com/"  target=&quot;_blank&quot;>Shop</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_entertainment" href="https://www.brazosvalleytheatre.org/"  target=&quot;_blank&quot;>Theater</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news~local-verify" href="/verify" >Verify</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_media" href="/video" >Media</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news" href="/video" >Video</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_news" href="/gallery"  target=&quot;_blank&quot;>Photos</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
                    <li class="navigation__item navigation__item_children_true">
                        <div class="navigation__sublist-activator">
                            <span class="navigation__label navigation__label_section_connect" href="/connect" >Connect</span>
                                <span class="navigation__expansion-indicator"></span>
                        </div>
                                <ul class="navigation__sublist navigation__sublist_visible_false">

                                    

                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/contact-us" >Contact Us</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/about-us" >About Us</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/advertise" >Advertise With Us</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us~team-bios" href="/meet-the-team" >Meet the Team</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/tv-listings" >TV Listings</a><div class="navigation__go-indicator"></div></li>
                                                <li class="navigation__subitem"><a data-tracking="navigation/linkClicked" class="navigation__sublink navigation__sublink_section_about-us" href="/rss" >RSS Feeds</a><div class="navigation__go-indicator"></div></li>
                                </ul>
                    </li>
        </ul>
    </div>
    </div>
    <div class="navigation__footer">
        <div class="navigation__live-indicator">
        </div>
        <div class="navigation__social">
                <a href="https://www.facebook.com/KAGSTV" target="_blank"><div class="navigation__icon navigation__icon_facebook"></div></a>

                <a href="https://twitter.com/intent/user?screen_name=KAGSnews" target="_blank"><div class="navigation__icon navigation__icon_twitter"></div></a>

        </div>
        <div class="navigation__copyright">&copy; 2019 KAGS-TV. All Rights Reserved.</div>
    </div>

</div>
        </div>
    </div>
</div>
            </div>
        

        <div class="page__main page__main_stand-alone_false">
            <div class="page__modal-overlay"></div>
            <div class="page__grid">
                
<div class="grid">
            <div class="grid__section-group grid__section-group_theme_default">
                    <div class="grid__section grid__section_top_true grid__section_sticky_none grid__section_theme_default grid__section_theme-changed_false" data-theme="default">
                        <div class="grid__gutter">
                        </div>
                        <div class="grid__content grid__content_top_true grid__content_theme_default grid__content_theme-changed_false">
                            <div class="grid__main grid__main_sticky_none">
                                <div class="grid__cell grid__cell_columns_3" data-columns="12">
                                    <div class="grid__module grid__module_top_true grid__module_ready_true" data-count="0" data-module="notification" data-module-id="">
                                        
                                        <div class="grid__module-inner grid__module-inner_ready_true">
<div class="alert-bar alert-bar_visible_false">
    <div class="alert-bar__list">
    </div>
    <div class="alert-bar__controls">
        <div class="alert-bar__close-button"></div>
        <div class="alert-bar__arrows alert-bar__arrows_visible_false">
            <div class="alert-bar__arrow alert-bar__arrow_side_left"></div>
            <div class="alert-bar__arrow alert-bar__arrow_side_right"></div>
        </div>
    </div>
</div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                        <div class="grid__gutter">
                        </div>
                    </div>



                <div class="grid__section grid__section_sticky_left grid__section_theme_default grid__section_theme-changed_false grid__section_previous-theme_default grid__section_next-theme_default" data-theme="default" data-next-theme="default" data-previous-theme="default">
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                        </div>
                    </div>
                    <div class="grid__content grid__content_theme_default grid__content_theme-changed_false">
                                <div class="grid__sticky-column grid__sticky-column_side_left">
                                    <div class="grid__sticky-content" data-columns="4">
                                            <div class="grid__module grid__module_fast_false" data-track-movement="false" data-module="ad" data-module-id="2d60ed3a-b39c-4bca-9d4c-a1dbd607e57f">
      <div class="ad ad_border_true ad_position_article_atf" id="article_atf" data-model-refresh="none" data-model-refresh-limit="3" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_atf&quot;,&quot;div&quot;:&quot;article_atf&quot;,&quot;sizes&quot;:[300,250]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;4cfb0912-d861-4a24-aed4-acbc9d293e00&quot;],&quot;main_front&quot;:[&quot;false&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;video_included&quot;:[&quot;true&quot;]}}"></div>
    <noscript>
        <div class="ad__nojs-placeholder" style="height:90px;border:2px solid #e6e6e6"></div>
    </noscript>

                                            </div>
                                            <div class="grid__module grid__module_fast_false" data-track-movement="false" data-module="docked-video-slot" data-module-id="d7dfc4a5-4f84-4c70-afda-726d3fc4168f">
<div class="docked-video-slot">
    <div class="docked-video-slot__inner"></div>
</div>
                                            </div>
                                    </div>
                                </div>
                        <div class="grid__main grid__main_sticky_left">
                                        <div class="grid__cell grid__cell_columns_2" data-starting-column="5" data-columns="8">

                                            <div class="grid__module grid__module_ready_true" data-track-movement="true" data-count="0" data-module="articles" data-module-id="f3f37245-83dd-402c-b229-87b7f61c4033">
                                                
                                                <div class="grid__module-inner grid__module-inner_ready_true">
<div class="article"
        data-dock-context-for="sharing title"
        data-model-title="&#39;Star Wars&#39; Day 2019: the 20 best May the Fourth deals"
        data-model-article="4cfb0912-d861-4a24-aed4-acbc9d293e00"
        data-model-section="money"
        data-model-subsection="consumer"
        data-model-topic="dealboss"
        data-model-subtopic=""
        data-model-gptId="493" 
        data-model-omnitureId="0" 
        data-model-comscoreId="1" 
        data-model-url="www.kagstv.com/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/507-4cfb0912-d861-4a24-aed4-acbc9d293e00" data-model-id="4cfb0912-d861-4a24-aed4-acbc9d293e00" 
        data-model-gpt="32805352/tx-collegestation-KAGS-B3362_DesktopTablet"
        data-model-hasvideo="true"
        data-model-iscontinuousscroll="false"
        data-model-categories="dealboss, money, consumer, entertainment, life"
        data-sharing-target="true"
        data-sharing-title="&#39;Star Wars&#39; Day 2019: the 20 best May the Fourth deals"
        data-sharing-url="www.kagstv.com/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/507-4cfb0912-d861-4a24-aed4-acbc9d293e00"
        
        data-model-author=""
        data-model-keywords="[
  &quot;dealboss&quot;,
  &quot;money&quot;,
  &quot;consumer&quot;,
  &quot;entertainment&quot;,
  &quot;life&quot;
]"
>
    <div class="article__article-story">
    <div class="article-story">
        <div class="article-story__lead-asset">
                            <div data-module="video" data-track-off-screen="true" data-track-movement="true">
        <div class="video"
             data-standalone="false"
             data-model-origin="video"
             data-video-url="https://www.kagstv.com/video/entertainment/buzz60/may-the-fourth-be-with-you-star-wars-superfan-celebrating-with-his-1400-figurines/600-8117375"
             data-grid-track="video"
             data-model-captions=""
             data-model-apiresponse="{&quot;Id&quot;:&quot;8117375&quot;,&quot;Sources&quot;:[{&quot;Format&quot;:&quot;HLS&quot;,&quot;Path&quot;:&quot;https://tgnafeed-vh.akamaihd.net/i/video/buzz60/8117375/8117375_,350,640,1000,2000,.mp4.csmil/master.m3u8&quot;,&quot;EncodingRate&quot;:1}],&quot;DateCreated&quot;:&quot;2018-05-04T13:23:00Z&quot;,&quot;SiteUrl&quot;:null,&quot;Image&quot;:&quot;https://media.kagstv.com/assets/BUZZ60/images/051131e2-7029-4deb-a63d-974d0566b3c8/051131e2-7029-4deb-a63d-974d0566b3c8.jpg&quot;,&quot;Title&quot;:&quot;&#39;May the Fourth&#39; Be with You! Star Wars Superfan Celebrating with His 1,400+ Figurines&quot;,&quot;Description&quot;:null,&quot;Origin&quot;:null,&quot;Advertising&quot;:{&quot;BrightcoveId&quot;:null,&quot;Section&quot;:&quot;entertainment&quot;,&quot;Subsection&quot;:&quot;buzz60&quot;,&quot;Topic&quot;:&quot;&quot;,&quot;Subtopic&quot;:&quot;&quot;,&quot;Enabled&quot;:true},&quot;VideoLength&quot;:&quot;56&quot;,&quot;Captions&quot;:&quot;&quot;}"
             data-model-autoplay="autoplay"
             data-model-dfpid="32805352"
             data-model-adsize="920x508"
             data-model-gptid="tx-collegestation-KAGS-B3362_DesktopTablet"
             data-model-omnituretag="0"
             data-model-videosplayedcount="1"
             data-model-endslate="jwplayer-related-plugin"
             data-model-embedsbaseurl="https://media.kagstv.com/"
             data-model-related-playlist-id="TqsgNNJI"
             data-model-related-media-id="tZdtlwr5">
                        <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__inner">
                        <div class="video__ratio-enforcer">
                            <div class="video__ratio-enforced" data-aspect-ratio>
                                <div class="video__player-container">
                                    <div class="video__player"></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                        <script type="application/ld+json">
                {
                "@context": "http://schema.org",
                "@type": "VideoObject",
                "name": "&#39;May the Fourth&#39; Be with You! Star Wars Superfan Celebrating with His 1,400+ Figurines",
                "description": "Even non-&#39;Star Wars&#39; fans know &#39;May the 4th&#39; is a special day, but this superfan knows exactly how to honor Star Wars Day.",
                "thumbnailUrl": "http://feed-download.akamaized.net/video/buzz60/8117375/8117375_Thumb.jpg",
                "uploadDate": "5/4/2018 1:23:00 PM",
                "duration": "56",
                "contentUrl": "https://www.kagstv.com/video/entertainment/buzz60/may-the-fourth-be-with-you-star-wars-superfan-celebrating-with-his-1400-figurines/600-8117375",
                "embedUrl": "https://media.kagstv.com/embeds/video/8117375/iframe"
                }
            </script>
        </div>

                            </div>
        </div>




        <h2 class="article-story__category article-story__category_section_consumer"><a data-tracking="article-story/categoryLinkClicked/dealboss" class="article-story__category-link" href="/section/money/consumer/dealboss">DEALBOSS</a></h2>


            <div class="article-story__lead-asset-caption">
            </div>

        <h1 class="article-story__headline grid__scroll-hook" data-scroll-hook-name="article-story__headline">&#39;Star Wars&#39; Day 2019: the 20 best May the Fourth deals</h1>
        <div class="article-story__abstract">
            May the fourth be with you! Here are some great deals for 'Star Wars' fans.
        </div>
        
    </div>
    <script type="application/ld+json">
        {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://www.kagstv.com/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/507-4cfb0912-d861-4a24-aed4-acbc9d293e00"
        },
        "headline": "&#39;Star Wars&#39; Day 2019: the 20 best May the Fourth deals",

            
                "image" : [],
            

        "datePublished": "5/1/2019 8:50:02 PM",
        "dateModified": "5/1/2019 8:50:02 PM",
        "author": {
        "@type": "Person",
        "name": ""
        },
        "publisher": {
        "@type": "Organization",
        "name": "KAGS",
        "logo": {
        "@type": "ImageObject",
        "url": "https://www.kagstv.com/content/logos/amp/kags.png",
        "width": 340,
        "height": 60
        }
        },
        "description": "May the fourth be with you! Here are some great deals for &#39;Star Wars&#39; fans."
        }
    </script>

    </div>
    <div class="article__story-highlights">

<div class="story-highlights">
</div>
    </div>
    <div class="article__author" data-grid-gutter-top="right">
    <div class="author">
        <div class="author__container">
            <div class="author__data">
                <div class="author__item">
                    <span class="author__tag">Author: </span>
                    <span class="author__name">
Matt Granite
                    </span>
                </div>
                <div class="author__item">
                    <span class="author__tag">Published: </span>
                            <span class="author__date">
                                3:50 PM CDT May 1, 2019
                            </span>
                </div>
                <div class="author__item">
                    <span class="author__tag">Updated: </span>
                        <span class="author__date">
                            3:50 PM CDT May 1, 2019
                        </span>
                </div>
            </div>
        </div>
    </div>

    </div>
    <div class="article__article-body">

    <div class="article-body">
        <div class="text">

                        <p><em>Get the biggest deals delivered to your inbox!&nbsp;</em><strong><a href="https://confirmsubscription.com/h/j/1146B10092D30C2A" target="_blank"><em>Click here to sign up for the DEALBOSS newsletter.</em></a></strong></p><p>"Star Wars" Day is Saturday, and it's a time for celebration and savings! The days that preceding and following Saturday are jam-packed with price drops and "Star Wars"-related deals.</p><p>Why is Saturday "Star Wars" Day? It's May 4, which gives fans an excuse to say "may the fourth be with you" — a take on a key "Star Wars" line: "May the Force be with you."</p>      <div class="ad ad_border_true ad_position_article_mid1" id="article_mid1_0" data-model-refresh="none" data-model-refresh-limit="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_mid1&quot;,&quot;div&quot;:&quot;article_mid1_0&quot;,&quot;sizes&quot;:[[300,250],[1,1],[750,570]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;4cfb0912-d861-4a24-aed4-acbc9d293e00&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;strnativekey&quot;:[&quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;],&quot;video_included&quot;:[&quot;true&quot;],&quot;ttid&quot;:[&quot;8117375&quot;]}}"></div>
    <noscript>
        <div class="ad__nojs-placeholder" style="height:90px;border:2px solid #e6e6e6"></div>
    </noscript>
<p>As a consumer reporter who has been searching through sales for a while, "Star Wars" Day deals get better each and every year. Below you will find some top fan favorite offerings. May the fourth be with you and your wallet!<br><br><a href="https://www.amazon.com/s/ref=as_li_ss_tl?k=B07B9YSLLJ%7CB01N240CLA%7CB077XZNNQC%7CB01BQ9S96A%7CB00SOFZTCW%7CB01N1495JT%7CB076M6H4B7%7CB072QN51ZG%7CB01DREMSWI%7CB06XWFJQ24%7CB01HBQNFV6%7CB00SD8IHU6&data=02%7C01%7CAndrew.Frankel@disney.com%7C992470d322f14f432dd608d6cced7e0a%7C56b731a8a2ac4c32bf6b616810e913c6%7C1%7C0%7C636921717907288671&reserved=0%3E&sdata=LrCOU30VdO4xewXmteiHIK3lFpkKsAJySKBwSY2ZUJI=&ref=nb_sb_noss%3Chttps://nam04.safelinks.protection.outlook.com/?url=https://www.amazon.com/s?k=B07B9YSLLJ%257CB01N240CLA%257CB077XZNNQC%257CB01BQ9S96A%257CB00SOFZTCW%257CB01N1495JT%257CB076M6H4B7%257CB072QN51ZG%257CB01DREMSWI%257CB06XWFJQ24%257CB01HBQNFV6%257CB00SD8IHU6&ref=nb_sb_noss&linkCode=ll2&tag=tegna-20&linkId=c7721cc8409fbf129418109d99db0c50&language=en_US" rel="noopener noreferrer" target="_blank">Amazon</a>: Hasbro "Star Wars" merchandise will drop by 20 percent on Saturday.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fwww.buildabear.com%2Fsale%2Fstar-wars-sale" rel="noopener noreferrer" target="_blank">Build-A-Bear</a>: Up to 50 percent off "Star Wars" bears through Saturday.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fcubcoats.com%2Fcollections%2Fstar-wars" rel="noopener noreferrer" target="_blank">Cubcoats</a>: $10 off $50 "Star Wars: Darth Vader and Chewbacca designs with promo code THEFORCE.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fwww.designbyhumans.com%2Fshop%2FStarWars%2F" rel="noopener noreferrer" target="_blank">Design By Humans Apparel:</a> 15 percent off most officially licensed "Star Wars" merchandise with promo code: MT4.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fwww.shopdisney.com%2Fstar-wars" rel="noopener noreferrer" target="_blank">Disney Store:</a> "Phantom Menace" lithograph for free to the first 50 guests who make a purchase on Saturday. A limited edition "The Phantom Menace"<em>&nbsp;</em>pin will also be given out.<br><br><a href="https://www.evine.com/Product/657-617" rel="noopener noreferrer" target="_blank">Evine:</a> 57-70 percent off Invicta watches until Sunday.<br><br><a href="https://fanwraps.com/starwars/" rel="noopener noreferrer" target="_blank">Fan Wrap:</a> Decals and accessories will be reduced by 20 percent on Saturday through Monday. A reminder, price drop is not valid until Saturday.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fwww.fifthsun.com%2Fbrands%2Ftv-movies%2Fstar-wars" rel="noopener noreferrer" target="_blank">Fifth Sun:</a> 20 percent off "Star Wars" gear and apparel until Sunday with coupon code: MT4.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fflexwatches.com%2Fcollections%2Fstar-wars" rel="noopener noreferrer" target="_blank">Flex Star Wars Watches:</a> 20 percent off all "Star Wars" watches with coupon code "maythe4th" valid on Saturday only.<br><br><a href="https://www.hallmark.com/shop-star-wars/?mc=T_P_LCNSR_NA_050419_ED_SW_HD_Fourth_off" rel="noopener noreferrer" target="_blank">Hallmark:</a> 25 percent off "Star Wars" merchandise plus limited pin sets for free with a purchase of $15 or more on select "Star Wars" gifts.<br><br><a href="https://www.heruniverse.com/shop-by-license/star-wars/" rel="noopener noreferrer" target="_blank">Her Universe:</a> Select "Star Wars" merchandise will drop by 30 percent on Saturday and Sunday.<br><br><a href="https://heroesvillains.com/" rel="noopener noreferrer" target="_blank">Heroes and Villains</a>: 25-50 percent off "Star Wars" merchandise Friday through Sunday.<br><br><a href="https://www.freecomicbookday.com/StoreLocator" rel="noopener noreferrer" target="_blank">IDW Comic Book Stores:</a> Free "Star Wars" comic books given out without any purchase required.<br><br><a href="https://search2.lego.com/en-US/star%20wars" rel="noopener noreferrer" target="_blank">LEGO</a>: Free art prints for LEGO VIPs and Hoth scene gifts with any LEGO "Star Wars" purchase of $75 or more in-store only Friday through Sunday.<br><br><a href="https://www.loungefly.com/brands/star-wars.html#page=1&top=1291&" rel="noopener noreferrer" target="_blank">Loungefly:</a> 25 percent off all "Star Wars" products until Saturday.<br><br><a href="https://outofprint.com/collections/star-wars" rel="noopener noreferrer" target="_blank">Out Of Print "Star Wars" Merchandise:&nbsp;</a>20 percent off select tees and shirts with coupon code STARWARS20 until Sunday.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fwww.popsockets.com%2Fcollections%2Fstar-wars-classic" rel="noopener noreferrer" target="_blank">Popsocket Phone Accessories:</a> Buy the entire "Star Wars" collection and save 40 percent off with coupon code "maythefourth" until Sunday.<br><br><a href="https://www.starwarsauthentics.com/iSynApp/showHomePage.action?sid=1102083" rel="noopener noreferrer" target="_blank">"Star Wars" Authentics</a><a href="https://www.starwarsauthentics.com/iSynApp/showHomePage.action?sid=1102083" rel="noopener noreferrer" target="_blank">:</a> Autographs are up to 50 percent off and all official photos are 30 percent off until Sunday.<br><br><a href="https://www.pubservice.com/subnew1page.aspx?PC=SW&PK=M95M4WB" rel="noopener noreferrer" target="_blank">"Star Wars" Insider Magazine</a>: Subscribe and score a free "Star Wars: Thrawn Alliances" novel through Sunday.<br><br><a href="https://go.skimresources.com?id=115148X1574271&xs=1&url=https%3A%2F%2Fwww.tervis.com%2Fstar-wars" rel="noopener noreferrer" target="_blank">Tervis "Star Wars" Mugs</a>: 20 percent off "Star Wars" mugs now through Saturday. On Saturday you'll also see limited edition stainless steel tumblers on the website as well.</p>      <div class="ad ad_border_true ad_position_article_mid2" id="article_mid2_0" data-model-refresh="none" data-model-refresh-limit="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_mid2&quot;,&quot;div&quot;:&quot;article_mid2_0&quot;,&quot;sizes&quot;:[[300,250],[1,1]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;4cfb0912-d861-4a24-aed4-acbc9d293e00&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;strnativekey&quot;:[&quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;],&quot;video_included&quot;:[&quot;true&quot;],&quot;ttid&quot;:[&quot;8117375&quot;]}}"></div>
    <noscript>
        <div class="ad__nojs-placeholder" style="height:90px;border:2px solid #e6e6e6"></div>
    </noscript>
<h2><strong>Who is Matt Granite?</strong></h2><ul><li><em>Matt Granite is a freelance consumer reporter who produces stories and video for this Station, Amazon and others. He is not compensated by the brands featured here. This Station and its parent company may receive a share of the revenue from the site that sells the product if you purchase one of these products using the link on this page.</em></li></ul><p><br><br></p><p><br><br><br><br></p>            
        </div>
    </div>
        <div id="taboola-below-article-thumbnails-2nd-0" data-model-page-type="article" data-model-ad="below_taboola" data-model-mode="thumbnails-h2" data-model-targetType="mix" data-model-placement="Below Article Thumbnails 2nd" data-model-url="http://www.kagstv.com/article/money/consumer/dealboss/star-wars-day-2019-the-20-best-may-the-fourth-deals/507-4cfb0912-d861-4a24-aed4-acbc9d293e00" class="taboola"></div>

    </div>
</div>
                                                </div>
                                            </div>
                                        </div>

                        </div>
                    </div>
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                                        <div class="grid__gutter-module" data-module="sticky-sharing">
<div class="sticky-sharing">
    <a data-tracking="sharing/twitterLink" class="sticky-sharing__icon sticky-sharing__icon_type-twitter" href="https://twitter.com/intent/tweet?text=[TITLE]&url=[URL]&via=[USERNAME]" target="_blank">
    </a>
    <div class="sticky-sharing__icon sticky-sharing__icon_type-facebook"></div>

</div>                                        </div>
                        </div>
                    </div>
                </div>
            </div>
            <div class="grid__section-group grid__section-group_theme_default">



                <div class="grid__section grid__section_sticky_none grid__section_theme_default grid__section_theme-changed_false grid__section_previous-theme_default grid__section_next-theme_default" data-theme="default" data-next-theme="default" data-previous-theme="default">
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                        </div>
                    </div>
                    <div class="grid__content grid__content_theme_default grid__content_theme-changed_false">
                        <div class="grid__main grid__main_sticky_none">
                                        <div class="grid__cell grid__cell_columns_3" data-starting-column="1" data-columns="12">

                                            <div class="grid__module grid__module_ready_true" data-track-movement="false" data-count="0" data-module="ad" data-module-id="2d60ed3a-b39c-4bca-9d4c-a1dbd607e57f">
                                                
                                                <div class="grid__module-inner grid__module-inner_ready_true">
      <div class="ad ad_border_true ad_position_article_flex_btf" id="article_flex_btf" data-model-refresh="none" data-model-refresh-limit="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;article_flex_btf&quot;,&quot;div&quot;:&quot;article_flex_btf&quot;,&quot;sizes&quot;:[[970,250],[728,90],[1140,286],[1,1]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;4cfb0912-d861-4a24-aed4-acbc9d293e00&quot;],&quot;main_front&quot;:[&quot;false&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;video_included&quot;:[&quot;true&quot;]}}"></div>
    <noscript>
        <div class="ad__nojs-placeholder" style="height:90px;border:2px solid #e6e6e6"></div>
    </noscript>

                                                </div>
                                            </div>
                                        </div>

                        </div>
                    </div>
                    <div class="grid__gutter">
                        <div class="grid__gutter-content">
                        </div>
                    </div>
                </div>
            </div>
</div>

            </div>
        </div>
            <div class="page__footer">
<div class="footer">
    <div class="footer__inner">
        <div class="footer__social">

<div class="social">
    <ul class="social__list social__list_align_center">
        <li class="social__item">
            <a class="social__link" target="_blank" href="https://www.facebook.com/KAGSTV">
                <span class="social__icon social__icon_type_facebook"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="17" height="16" viewBox="0 0 17 16">
    <image id="Vector_Smart_Object" data-name="Vector Smart Object" width="17" height="16" xlink:href="data:img/png;base64,iVBORw0KGgoAAAANSUhEUgAAABEAAAAQCAQAAABaOFzUAAAABGdBTUEAALGPC/xhBQAAACBjSFJNAAB6JgAAgIQAAPoAAACA6AAAdTAAAOpgAAA6mAAAF3CculE8AAAAAmJLR0QAAKqNIzIAAAAJcEhZcwAACxIAAAsSAdLdfvwAAAAHdElNRQfhAhENOQMc/E5OAAAAlklEQVQoz73PMQtBARTF8d+ToiyGV4oSWQ0+gEL5GL6Ewax8G5OdwWozyOYVC4MimwmTAe+xOdu9/e895wSzjZpvioLZ3Q+lY7cHY3s5PbV4ZKnjAhpJyNBFoKuknGS0Rsv0OaZikBvySXHPRjhhpY+BIq+ldyovJ0fh+5esNhauQnUZ4adRwRxVW02Tb3Hf9Eck+kFED4KVHWZAZTHbAAAAAElFTkSuQmCC" />
</svg></span>
            </a>
        </li>

        <li class="social__item">
            <a class="social__link" target="_blank" href="https://twitter.com/intent/user?screen_name=KAGSnews">
                <span class="social__icon social__icon_type_twitter"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="19" height="16" viewBox="0 0 19 16">
    <image id="Vector_Smart_Object" data-name="Vector Smart Object" width="19" height="16" xlink:href="data:img/png;base64,iVBORw0KGgoAAAANSUhEUgAAABMAAAAQCAQAAABezYzpAAAABGdBTUEAALGPC/xhBQAAACBjSFJNAAB6JgAAgIQAAPoAAACA6AAAdTAAAOpgAAA6mAAAF3CculE8AAAAAmJLR0QAAKqNIzIAAAAJcEhZcwAACxIAAAsSAdLdfvwAAAAHdElNRQfhAhENNjO9vWItAAABFUlEQVQoz33QPUhbARAA4O89k4qDXRrMIrgFwSkuLlJSea3oVoRu4i4IHerk5Jyhi44uDg4KHS3tg9JBLLQFaSQVERGh0EBpJHFQNJYOJs0PTW66n2+4uyDmkd/aIy1vTr/Pln2Scx3Egw49ddKCHvoiU89vlVVNhDJG7JtsYYv/EElpJa9CVaR89FqqPsp1rHBuNYg5MgquvLGrYN3jNjYU/QritCkbBnSPZFRLGLLlrgcqRTVCRd/19WB7EPpjQaUHe3vP+GrJjy6oYqfByBruwvLRZZOtePdf9E3+PgnrH5sxq9iBfnruppU9EHlprA2deuKsUYReOHDhvWct5M6arONmI2HbB/OmjUsJlBXENjsv/wvGUENgDcdadwAAAABJRU5ErkJggg==" />
</svg></span>
            </a>
        </li>


    </ul>
</div>
        </div>
        <div class="footer__menu">
            <ul class="footer__list">
                <li class="footer__item"><a class="footer__link" href="/terms">Terms of Service</a></li>
                <li class="footer__item"><a class="footer__link" href="/privacy">Privacy Notice</a></li>
                <li class="footer__item"><a class="footer__link" href="/privacy">Your California Privacy Notice</a></li>
                <li class="footer__item"><a class="footer__link" href="/adchoices">Ad Choices</a></li>
                        <li class="footer__item"><a class="footer__link" href="https://interactive.kcentv.com/pdfs/Waco_Temple_Bryan_TX_EEO_Public_File_2018_2019.pdf">EEO Public File Report</a></li>
                        <li class="footer__item"><a class="footer__link" href="https://publicfiles.fcc.gov/tv-profile/kcen-tv">FCC Online Public Inspection File </a></li>
                        <li class="footer__item"><a class="footer__link" href="/closed-captioning">Closed Captioning Procedures</a></li>
            </ul>
        </div>
        <div class="footer__copyright">
            &copy; 2019 KAGS-TV. All Rights Reserved.
        </div>
    </div>
</div>
      <div class="ad ad_border_true ad_position_exit_interstitial" id="exit_interstitial" data-model-refresh="none" data-model-refresh-limit="none" data-model-settings="{&quot;ad&quot;:{&quot;name&quot;:&quot;exit_interstitial&quot;,&quot;div&quot;:&quot;exit_interstitial&quot;,&quot;sizes&quot;:[[1,1]]},&quot;targeting&quot;:{&quot;pgid&quot;:[&quot;4cfb0912-d861-4a24-aed4-acbc9d293e00&quot;],&quot;pgtype&quot;:[&quot;article&quot;],&quot;strnativekey&quot;:[&quot;tjn5Bu7BjYyyfAFHyJYcG21v&quot;],&quot;video_included&quot;:[&quot;true&quot;],&quot;ttid&quot;:[&quot;8117375&quot;]}}"></div>
    <noscript>
        <div class="ad__nojs-placeholder" style="height:90px;border:2px solid #e6e6e6"></div>
    </noscript>
            </div>
        <script src="/scripts/require-2.3.3.min.js"></script>
        <script>

        (function() {
            var modules = [
                'error',
                'page',
                'grid',
                'desktop-header',
                'toolbar',
                'weather-summary',
                'navigation',
                'video',
                'throbber',
                'utils',
                'fitted-headline',
                'forecast',
                'article',
                'continuous-scroll',
                'sharing',
                'gallery',
                'radar-gallery',
                'forecast',
                'article-crosspromo',
                'featured-videos',
                'chapter-slider',
                'pollen',
                'olympics-live-stream',
                'three-day-outlook',
                'current-weather',
                'search-results',
                'tracking',
                'chapter-progress',
                'progress',
                'countdown-clock',
                'longform-explore',
                'media-gallery',
                'social-sharing',
                'weather-alerts',
                'weather-interactive-radar',
                'closings',
                'tealium',
                'alert-bar',
                'cookie',
                'sticky-sharing',
                'live-indicator',
                'sharethrough',
                'taboola',
                'elections',
                'just-for-you',
                'just-for-you-li',
                'olympics-tv-listings',
                'headline-list-with-abstract',
                'text-only-headline-list',
                'story-snapshot-with-abstract',
                'snapshot',
                'story-snapshot',
                'special-content-headline-list',
                'notfound',
                'linked-image',
                'article-recirculation',
                'linked-image-with-title',
                'newsletter-signup',
                'linked-image-with-title',
                'newsletter-signup-multiple',
                'live-videos',
                'breaking-news',
                'weather-alerts',
                'closings',
                'media-gallery-alt',
                'alert-center-menu',
                'trending-list',
                'toc',
                'featured-radars',
                'searchbox',
                'hot-races',
                'recirculation',
                'photo',
                'video-youtube',
                'tegna-utils'
            ];
            require.config({
                'baseUrl': '/',
                'deps': modules,
                'waitSeconds': 30,
                'bundles': {
                    'modules': modules
                },
                'paths': {
                    'jquery': 'scripts/jquery-3.1.1.min',
                    'jwplayer': 'content/player/jwplayer.js?version=3.7.2',
                    'modules': 'Views/dist/scripts/modules.min.js?version=3.7.2',
                    'facebook': 'https://connect.facebook.net/en_US/all',
                    'twitter': 'https://platform.twitter.com/widgets',
                    'slick': 'content/libs/slick/slick.min',
                    'dotdotdot': 'content/libs/dotdotdot/jquery.dotdotdot.min',
                    'jqueryui': 'Views/lib/jquery-ui/jquery-ui.min',
                    'comscore': 'content/libs/comscore/comscore.min',
                    'stickyfill': 'content/libs/stickyfill/stickyfill.min',
                    'youtube': 'https://www.youtube.com/iframe_api?noext'
                },
                'shim': {
                    'facebook': {
                        'exports': 'FB'
                    },
                    'twitter': {
                        'exports': 'twttr'
                    },
                    'youtube': {
                        'exports': 'YT'
                    },
                    'jwplayer': ['jquery'],
                    'jqueryui': {
                        'deps': ['jquery']
                    },
                    'slick': ['jquery'],
                    'dotdotdot': ['jquery']
                }
            });
        })();
        </script>

        <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>	
        <script type="text/javascript">	
            var recaptchaCallback = function () {	
                window.grecaptcha = grecaptcha;
            }	
        </script>
        <script type="text/javascript" src="//cloudfront.loggly.com/js/loggly.tracker-latest.min.js" async></script>
        <noscript>
            <style>
                .grid__module {
                    height: auto;
                    opacity: 1;
                }
            </style>
        </noscript>
    </body>
</html>
